ray985

Members
  • Content count

    10
  • Joined

  • Last visited

  1. Thanks for the input. Here's the URL to the page. http://briteswitch.com/Creeden/print.php?EstimatorID=103 On this page it's the nth-of-type(1) but still having the problem with the extra aggregation columns showing. I've fiddled with it a lot but can't figure out how to get rid of those.
  2. I have a datapage where I'm hiding some columns of calculated fields using CSS below. #target table:nth-of-type(2) td:nth-of-type(10) {display: none;} #target table:nth-of-type(2) th:nth-of-type(10) {display: none;} #target table:nth-of-type(2) td:nth-of-type(11) {display: none;} #target table:nth-of-type(2) th:nth-of-type(11) {display: none;} That works great, but it doesn't hide the columns in the aggregation rows so I have an overhang of dark grey in my table (see picture). I think the problem is that in the totals rows, text spans multiple columns, so it's not really column 10 and 11 I have to hide in these rows. Does anyone know how to target these cells and hide them?
  3. Posted in the wrong section. I have a datapage where I'm hiding some columns of calculated fields using CSS below. #target table:nth-of-type(2) td:nth-of-type(10) {display: none;} #target table:nth-of-type(2) th:nth-of-type(10) {display: none;} #target table:nth-of-type(2) td:nth-of-type(11) {display: none;} #target table:nth-of-type(2) th:nth-of-type(11) {display: none;} That works great, but it doesn't hide the columns in the aggregation rows so I have an overhang of dark grey in my table (see picture). I think the problem is that in the totals rows, text spans multiple columns, so it's not really column 10 and 11 I have to hide in these rows. Does anyone know how to target these cells and hide them?
  4. I have a datapage with several columns of data as well as 3 columns of calculated fields. Currently, these fields are then summed in 3 different aggregation rows at the bottom of my table. Having 3 separate rows is not ideal visually. Also, if possible, I would like to ability to use them in HTML (ie, say "You saved $xx this year). Is there any way to do this? I can't find a way to refer to the aggregate values in the footer or to have it sum the calculated values in the footer itself. (ie SUM([@Savings#]).
  5. Thanks. That did the trick. For anyone else that has the same problem, here's the code I ended up using in the calculated field box. I passed the parameter "wattsaved" in the URL to Caspio which came from a textbox in my form. CASE WHEN [@field:Per]='watt saved' THEN ([@field:Rebate] * '[@wattsaved]') WHEN [@field:Per]='kW saved' THEN ([@field:Rebate] * ('[@wattsaved]' / 1000)) ELSE 0 END
  6. I have a report that has a calculated field in it that is based on a conditional statement. For one of the options, I would like it to multiply a field by the value of an input box. I can't figure out how to do it though. I've tried passing the value as an external parameter in the URL but I can't figure out how to reference that in the calculated field formula. Right now the input field is on the web page that the Caspio iframe is embedded on, but I can also move the input to the header of the form if that would help. Is there a way to do this? I'm using the code below... CASE WHEN [@field:Per]='lamp' THEN [@field:Per] * 2 WHEN [@field:Per]='fixture' THEN [@field:Cost] * EXTERNALPARAMETER ELSE 0 END
  7. External Parameters Not Clearing

    I'm trying to pre-filter a datapage based on an external parameter I pass along in a URL query. It's worked for me with no problems before, but for one page, I'm having a problem that once I use one parameter, if I try any other URL with another parameter, the first one seems stuck in the system. For example, I'll have this link filter the results for Colorado: http://b4.caspio.com/dp.asp?AppKey=e2742000bfd7874f295c475987ea?State1=CO Then If I go to think link to filter for NJ, it still shows the Colorado results. http://b4.caspio.com/dp.asp?AppKey=e2742000bfd7874f295c475987ea?State1=NJ I can't seems to figure out what's causing the problem. I've changed the parameter's names, recreated the table and database, and nothing has helped. Any suggestions? Thank you, Randy
  8. I use authentication to have members login to see a few different datapages on my site. I would like to capture the date when they log in, so I can have a record of who is accessing the data on which days. I can't add a timestamp field to the authentication page and I've tried using the javascript for date/time insertion that is in the forums (JS: Automatically insert the current date/time into a field) but neither is working. Is there a way to capture the date?
  9. Formatting Yes/No Field in Database

    Thanks. That makes sense. I was just looking for a way to show results as a check mark or check box. Instead of a columns of "Y" or "N", just have checks or no checks. I just think it looks a lot nicer on a results page than Y or Ns, but I can't figure out how to do it.
  10. Formatting Yes/No Field in Database

    I'm working on a datapage and I have a yes/no column on this page. Instead of the column showing either "Yes" or "No", I would like it to show check marks to represent Yes and blanks to represent no. I tried changing the formatting settings for this field to custom, but I can't find out how to make a custom check mark symbol; there doesn't seem to be one in the font and it doesn't seem to accept images. Is there anyway to do this?