Jump to content

waltmayo

Caspio Ninja
  • Posts

    42
  • Joined

  • Last visited

  • Days Won

    4

Posts posted by waltmayo

  1. I've set up a single record update datapage to accept incoming value for email and to update a single field value in that record that matches that email address. I've added this url to Gravity Forms Webhook add-on and everything looks right, but the form never updates the record or sends me notification. I've added auto-submit and the url works if I enter it manually in a browser... https://c0esh132.caspio.com/dp/123456789101112131415/?Email=johndoe@gmail.com  ... but the same URL never fires when I call it using the Gravity Form. I've subsituted a requestbin url to test and make sure the proper value is being passed along... and it is.   I've also tried doing the same thing with a Zapier Webhook... and again, the caspio form never fires.

    Help!

  2. Please forgive me if this is a re-hash... but I've searched and not really found a solid answer. Can charts auto-refresh from data changing in the table their are connected to? I'll go to conference and see charts that fluidly change as people enter data into their phones, tablets, audience response devices, etc. Is such a smoothly updating chart possible with Caspio?

  3. Setting a field as unique will prevent users from submitting data that duplicates value in that specific field. Easy enough... but is it possible to flag TWO fields to be unique as a "set" of sorts so say... a specific USERID couldn't submit two reports with the SAME TITLE... but the title field isn't unique because other users might submit a report or purchase a product with the same title?  This would prevent a user from submitting the same data twice... by monitoring the USERID _and_ the TITLE field, as an example. Neither is unique in the table design, but no entry into the table could be the same combination of USERID and TITLE.  I'm rambling and repeating myself, but wanted to make sure I convey what I'm after.

  4. I have used Joomla for years... and often embed Caspio data inside articles using the standard javascript embed. It works fine as long as I make sure Joomla's settings are such that the scripting is not filtered out. This has worked great up until Joomla 3.3. I have all script filtering turned off, but the embed scripts are not working... giving up just a blank page. Other scripts I've tested work fine... so it's not that Joomla 3.3 won't allow javascript... it's just the Caspio standard embed script.

     

    Help!

     

    Walt

  5. Simple script... checks a field value... if not blank, it ".writes" the value to HTML... if it is blank, it uses the data from a different field. If the variable value has an apostrophe in it, the whole thing returns a blank string. It obviously breaks the code. There are many reference to this type of thing on the web, but NONE of the solutions I've tried have worked. Below is a sample, including code to escape the apostrophe with a "\" character. Doesn't work...  HELP!

     

    <script>

     

    var X='[@field:Event_Name_Override]';

    var Y='[@field:Event_Name]';

     

    X = X.replace(/\'/g, "");

    Y = Y.replace(/\'/g, "");

     

    if (X.length>1)

    {

    document.write(X);

    }

    else

    {

    document.write(Y);

    }

    </script>

  6. WOT is now telling any user that visits a site using b6.caspio.com as a bad site, with phishing activity. It's a ridiculous result of flagging the entire server as a bad site due to a single caspio report/form, the URL of which they cite at:

     

    https://www.phishtank.com/phish_detail.php?phish_id=2044327

     

    Phishtank has deactivated the post, taking it "offline" but you can still see it  (but can't respond). WOT continues to use this single inactive report to flag the entire server.

     

    If there is ANYTHING you can do to contact WOT and rectify this, it would be MOST appreciated.

     

    Walt

  7. No, the problem is that authenticated forms/reports don't get displayed at all in iframes due to Safari, and now Firefox rejecting cross-domain (3rd-party) cookies. Not sure there is a thing that can be done about it, but it makes using any authenticated forms/reports inside an iframe basically useless. IE doesn't like them either, asking to "Allow all content to be displayed", which many users ignore or don't notice.

     

    So basically, I can't have authenticated forms/reports inside Joomla using iframes (wrappers). I have to kick the user out to to a raw (non-embedded, non-iframed) Caspio url. Very clunky.

     

    Since this problem seems so rarely discussed here I am hoping I am just dumb and missing some basic rule for using authenticated forms/reports in iframes. 

     

    I absolutely LOVE Caspio but this problem is becoming a major league headache for me.

     

    Walt

  8. No, I don't... simple setup on my end... Joomla wrappers work fine for public Caspio forms and reports. But when they are authenticated forms/reports, the nightmares begin. Always works fine in Chrome, never works in Safari when 3rd-party cookies are not accepted, and now it's acting super-flaky in the latest Firefox. It's really a HUGE problem as I have spent over a year building a system using Joomla as the "template" and menu system, with Caspio as the "guts" of the system, and now it's all basically broken. I am gradually moving forms and reports outside Joomla to get rid of the iframe problem, but this is unacceptable long-term. It's just a clunky mess at the moment. I've been asking for help for over a month and get basically no help. For someone spending over $500/mo on Caspio, this is very frustrating.

     

    Walt

  9. I have researched this and it is due to a situation where Safari will not accept cookies in an iframe unless Safari is set to ACCEPT ALL COOKIES. This is not the default. There are some php work-arounds that are listed, but I am unclear as to how to implement any of them.

     

    http://stackoverflow.com/questions/9930671/safari-3rd-party-cookie-iframe-trick-no-longer-working

     

    Surely someone has dealt with this before regarding authenticated Caspio apps running inside a Facebook iframe.

     

    Help!!

     

    Walt

  10. I've got a folder that requires authentication. The datapages in the folder often call one another in a multipage approach. During use of the "app" in an iframe installed as a Facebook App the Caspio pages ask for username and password repeatedly at odds times. The session seems broken randomly as you work through the various pages.

     

    Seems far worse with Safari...

     

    Thoughts?

     

    Walt

  11. I have a simple report... it accepts a file_id to display a single item/record. I have the "allow delete" checkbox toggled on. Sooo... if I call the report, data is displayed for a single record and a DELETE button is visible. I would like to be able to autosubmit the form. I've used code from this forum to do this... but it loops. Any help would be appreciated!

     

    Or any other method to delete a single record by code of some kind...

     

    Walt

  12. I've created a style called NO_STYLE and cleared every setting. Yet when I deploy a page there is still a ton of code generated by Caspio. I am trying to create a report that outputs an RSS feed, but cannot seem to do so because of all the default extra "stuff" Caspio writes at the top of each file. Is there any way to turn EVERYTHING off so that all that shows up is the code that I define in the report?

    Walt

  13. I am in need of some help with integrating Javascript into some of my apps.

    I know that the Caspio team will take on custom programming jobs, but these tasks are sometimes very small. Does anyone else out there do freelance Caspio work? I'm not opposed to hiring Caspio's programmers, just was interested in learning all my options.

    Walt

  14. I've read the SEO guidelines several times, but was hoping there is a way to pass a parameter to a report being SEO deployed. For instance... if I have 50 "articles" in a table, and want to display just one, can that be done by passing a parameter, or do I have to set up 50 different datapages?

    Walt

×
×
  • Create New...