Jump to content

mbdiener

Members
  • Content Count

    4
  • Joined

  • Last visited

  • Days Won

    2

Posts posted by mbdiener


  1.  

    @AtayBalunbalunan,

    Thanks for your reply. I am deploying the Datapage on a self hosted WordPress website. I've tried it both using the Embed and WordPress (with plug-in) deploy methods.

    I tested the direct link in Firefox, I did see the authentication fields. I then tried the page on Microsoft Edge and that worked. On a whim, I decided to try it again on Firefox and now the fields display! I really don't know how to explain it, but it probably has something to do with cache and/or cookies, which I did clear when previously testing.

    I guess as long as it continues working it will be one of the great unsolved mysteries.

    Thanks for you assistance!!

     


  2. I created a login page on my website in order to authenticate to Caspio for data inserts and updates. The login page is a data page with required authentication with username and password fields. When bringing up the page in Firefox, the " Create a Free Online Database /Disclaimer: This is a Caspio free app. Do not submit passwords or other sensitive data. Report Abuse" tagline appears but the username and password fields do not. When bringing up the same page in Chrome, the fields do appear.

    In comparing code in developer tools for both browsers, Firefox seems to be replacing all of the <tbody> data that defines the fields that I see in Chrome with <noscript></noscript> tags.

    I'm at a loss as to how to further troubleshoot. Any assistance would be greatly appreciated.  I would go to support but, alas, as a newbie trying out Caspio, I'm still in the Free Plan.


  3. @Alison,

    Thanks for your reply. Your comments regarding the Authentication configuration made me realize what the problem was. The authentication Caspio method automatically chose the UserID and password for authentication. However, the UserID was the autogenerated unique record number, not the Username, which I was inputting. I changed the method to use the Username and all worked fine!

    Thanks again for answering.


  4. I've looked through the forum for help on this issue and although I found a posting or two, it doesn't seem to provide any additional info.

    • I created a "user" datapage with auto-generated ID, username and password.
    • I created an authentication using the same datatable and the Caspio data source setting.
    • Last, I created a login page datapage with authentication required to the authentication I created. I deployed this page and chose the embed method to embed the login page to my WordPress site.
    • I have added a test login to the users table.

    Each time I login with the test credentials, I get the message "Authentication failed. The information you have provided cannot be authenticated. "

    Going through the forums I found a troubleshooting page that simply says make sure you're using the correct ID and password, caps lock is off and cookies are allowed on the page. I have done all of this but am still getting the error.

    I am new to Caspio and am using a "Free" account. Is there a step I'm missing or something else I should be looking at?

    TIA

×
×
  • Create New...