Jump to content

CoffeeLover

Members
  • Posts

    21
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

CoffeeLover's Achievements

  1. Hi All, Just an update... I have just spoken with the Caspio support team and Tablet views are treated the same as a mobile device. "The browser's on the tablet is still being considered as a mobile platform thus triggering the responsive function. As mentioned, you may want to try disabling the responsive function on the datapage to make the page appear on mobile as it was on PC browsers". If I disable the responsive function on the Datapage then all mobile phones won't be able to use the App as the display would be to large. Support did say they could write a custom script to fix this but obviously that would require $$$. Kind regards CoffeeLover
  2. Hi @Meekeee, Thanks for the documentation. I am still having no luck in getting columns to display on the iPad. I made a real simple Datapage 3 columns wide which display fine on PC. But on the iPad I still only see 1 column. I even downloaded Chrome for my iPad but that is doing the exact same thing and only displaying 1 column. Is there a .cb command to set number of columns? I can't find that anywhere under Styles? I think Styles is just for CSS? I am at an absolute loss as to why I can't get multiple columns on the tablet for a Gallery View Datapage. Kind regards CoffeeLover
  3. Hi All, Also is there a way I can define the number of columns depending on the device the user is on? Example - PC 3 columns, Tablet 2 columns and Mobile 1 column? Thanks CoffeeLover
  4. Hi All, I have several Datapages using Datapage type Gallery View. They work fine on PC (shows the 2 columns) and works fine on mobile (only shows one column). On PC it adjusts perfectly to the size of the screen on my laptop and PC. However on my iPad (Safari 14.0) it seems to default to the mobile view and only shows one column. I adjusted the data size so it could easily fit 4 columns but it still only ever displays one column. I thought it may have been something to do with Webstarts and the embed Datapage option so I also ran the Datapage from the direct URL and it still only displays one column. All my Datapages have Enable responsive selected and I don't have any custom code in my Datapages (eg HTML blocks etc). Do I need to adjust any settings in my Datapage Select Style? Could it be a setting on my iPad causing the issue? I am really stumped as to why it won't show multiple columns on the iPad. Any suggestions? Kind regards CoffeeLover
  5. Hi @Georgeg, Yes it can work with most countries. Twilio lets you set which countries you can send SMS too under Geo Permissions. Regards CoffeeLover
  6. Hi @MattD, That is a wonderful solution. Well done! CoffeeLover
  7. Hi @Meekeee, Thanks for the link. I had a look at this yesterday in regards to cookie settings required in Safari. I can confirm that Safari works perfectly with my app. Kind regards, CoffeeLover
  8. Hi @Meekeee, Thanks for your response. I'm not going to worry about the Facebook App browser as I have read most people disable it and use Safari or Chrome. I am doing some testing on a IPhone using Safari today and I'll let people know if Safari acts the same way as Chrome. Kind regards CoffeeLover
  9. Hi All, While I'm looking at different browser issues... Does Safari on IPhone and Mac support window open in new tab / window? (Like Chrome does) Does Safari on IPhone and Mac support window close automatically command? (Like Chrome does) Kind regards CoffeeLover
  10. Hi All, I am doing some tests on my app in different browsers and have found some issues if viewing the website on the Facebook App. It seems the Facebook App does not allow you to open a new tab / page in their browser. I have a Datapage where on the results page users can click a button which opens another window showing more details. It works perfectly in Chrome 90, Chrome 95 and the Twitter App. But with FB it opens this window in the same window / tab and when the user presses the back button it always returns to the Datapage form page and not the previous results page. Also I have noticed the FB App does not allow "automatically close window" which two of my Datapages use. I am interested if anyone else has experienced this and has a solution / work around? ---- To be honest it's not a massive issue as I doubt many would be viewing my site on this app. ---- Kind regards CoffeeLover
  11. Must admit I have never experienced this issue even when on the free plan. Is the Datapage embedded on a page or are your clients using the Datapage via direct link? As NiceDuck suggests you may have a trigger altering or deleting the record. Regards CoffeeLover
  12. Hi @Meekeee, Yes I have had no issues with passing parameters either by URL or by Caspio Datapage to Datapage. Most my parameter passing is done through Caspio but I have a few instances where I use JotForms where I pass parameters by URL back to Caspio forms. You do need a paid account to be able to embed HTML such as Caspio datapages. Cheers CoffeeLover
  13. Hi All, I use Webstarts which works well with datapage integration. You will need a paid account to be able to embed your datapages. The only minor issues I have came across is datapage headers sometimes has issues in displaying correctly. Cheers CoffeeLover
  14. Hi @KlisaN137, I really appreciate the time you have taken to help me out. I think my best bet is to change my workflow or possibly create another table to pull this data from. Kind regards CoffeeLover
  15. Hi @KlisaN137, Thanks for your reply. I will try and explain my work flow a bit better. I have 2 datapages both using the same authentication to login. - Edit Profile Setting - Quick Search Quick Search datapage gets the users preferences (which are set in Edit Profile Setting) and searches based on that criteria. There is no form for this search. If a user changes their preferences in Edit Profile Setting the data is updated however all auth fields remain the same and only update when the user logs out and logs back in. For example - A user logs in with the authentication and changes the criteria from "Accounts" to "Human Resources" in Edit Profile Setting. The data updates to "Human Resources" but the auth field remains "Accounts" until the user logs out and logs back in. I am trying to find a way where the auth fields refresh with the new values without the user having to logout and log back in. Hope this is clearer. Kind regards CoffeeLover
×
×
  • Create New...