Jump to content

Search the Community

Showing results for tags 'Undefined'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Caspio Bridge
    • General Questions
    • Caspio JavaScript Solutions
    • Tables, Views and Relationships
    • Import/Export and DataHub
    • DataPages
    • Deployment
    • Security, Authentications, Roles, SAML
    • Styles and Localizations
    • Parameters
    • API and Integration
    • Calculations and aggregations
    • User JavaScript and CSS Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Skype


Location


Interests

Found 1 result

  1. I am having trouble using String Query parameter passing. I am embedding html into the results of an Search and Report datapage. This html <a href="JavaScript:newPopup('http://b6.caspio.com/dp.asp?AppKey=1e433000d19de0725b604d9ea93d?Client=[@field:Client]&Client_ID=[@field:Client_ID]');">[@field:Client]</a> This way a user can click on the Client Name hyperlink which calls Add_Relationship data page and maps the logged in users name to the sent Client and Client ID. However every time I try and use this link I get, Undefined AppKey. (Caspio Bridge error) (60011). I also have another data page, Add_Client, that adds a client to a data table then on exit loads the Add_Relationship data page and passes all the required parameters. When I go from data page to data page it works fine, the only issue I have is when I try and use string query parameter passing. If I remove everything after ? the data page loads fine, obviously without the parameters but that defeats the purpose. All three data pages are enabled and have both, Advanced and Parameters, check boxes marked. The Add_Relationship data page has has 3 fields, the Username is set for, OnLoad receive an Authentication field, and Client and Client_ID which both receive external parameters, [@Client] and [@Client_ID]. This is my first attempt using string query so I dont know what I am doing wrong. I have gone over the Receiving Parameters How To, and the String Query How To pages, but it Looks like I have everything set the way it should be. Any help is appreciated, Thank You.
×
×
  • Create New...