Jump to content

Search the Community

Showing results for tags 'filter criteria'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Caspio Bridge
    • Caspio Apps for Ukraine
    • General Questions
    • Caspio JavaScript Solutions
    • Tables, Views and Relationships
    • Import/Export and DataHub
    • DataPages
    • Deployment
    • Security, Authentications, Roles, SAML
    • Styles and Localizations
    • Parameters
    • API and Integration
    • Calculations and aggregations
    • User JavaScript and CSS Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Skype


Location


Interests

Found 2 results

  1. Hey! I have created a basic table with some basic data, then I created a data page with some filter and grid edit capability, and then the following happened: I used the filter and got some data that I wanted to modify. I switched to grid edit mode, then made modifications on a record, I have modified the data that I used to filter by. Then I clicked out from this row, It saved it successfully. It was still in the grid edit list, even though it no longer met the filter criteria. But I clicked back to this row, to make one more modification on a data, but when I tried to click out to save, it threw this error: No record found. 1. Filter by Search flag: 2: Modified and saved the Test row Search Flag to No (Note: Filtered by search flag to be marked): 3. Clicked back to the second row to modify the Name too. I tried to rename Test to Test1 4. When I tried to save (with clicking out) I have got the error above. Is there any workaround to this problem? Well it looks like a bug to me, and already reported this. But maybe somebody have a trick to this.
  2. I have a data page where I am trying to apply 2 filter criteria (Account ID and Contact ID). My record can have one of these IDs or both. The page will receive only one external parameter (either Account (aid) or Contact (cid)) and any record with either or both of these values should display if there is a match on aid of cid. However it will only display if in my record both aid and cid are populated. If I pass only the aid, it only display records with both the matching aid and a cid value populated. My records that only have the aid (which is a match), do not display. Also, I have attempted every variation of "value required", "If empty, match blank values only", etc . . . . still no success. To get this to work, I have to create 2 data pages (1 for aid and for cid) with only 1 filter criteria. Can UI not do this in 1 data page using 2 criteria?
×
×
  • Create New...