Hello! Instead of using script to pass parameter with ampersand, you can just use a simple formula. You need to change the ampersand to URL encoded character. Add Calculated Value/ Calculated field and use: replace('[@field:FIELDNAME]','&','%26') Then, pass this field as parameter instead of the actual field. Lastly, hide this field so it will not be visible in the form. https://howto.caspio.com/tech-tips-and-articles/common-customizations/how-to-hide-fields-in-datapages/