Jump to content
  • 0

3rd Party Cookies warning keeps appearing


HeyItsDoug
 Share

Question

I've been working on this app for several months now and have never had an issue with this - the warning about enabling 3rd party cookies is now appearing at the top of every data page.  BUT - only when I execute a search from a dropdown or text box.  If I just go from datapage to datapage the warning does not appear.  But as soon as I drop down a list and select another employee, in on instance, the search completes but the warning appears at the top of the page.  Then if I click to go to a different module the warning does not appear on that next datapage. I have ensured multiple times that all browsers are accepting 3rd party cookies. I'll also mention that this happens on all three computers in my office.  BTW, all authentications are working as usual and I have double-checked to ensure cross-app logins are enabled.\

Any ideas?

THANK YOU

Doug

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hi there @HeyItsDoug! I was looking at Caspio's  system requirements article ->https://howto.caspio.com/system-requirements/#:~:text=Session Cookies,issues filtering data in reports.

and saw that third-party cookies or cross-site tracking prevention settings are related to displaying system messages to notify users of the issue. 

However, since you mentioned you already made sure that your browsers are already accepting cookies and still get this error message in specific times, I can suggest reaching out to Support for further help: https://www.caspio.com/support/

I genuinely hope you finally find a solution for this. :)

 

- Jihyo 

Link to comment
Share on other sites

  • 0

Hello, just to add, there is actually an option to change the link to get redirected to your own website. For example, I do not want users to know that I am using Caspio so I do not want them to be redirected to the System Requirements. What I did is I created an instructions inside my own site similar to what Caspio had mentioned on this link https://howto.caspio.com/system-requirements/ and I basically just changed the link of the localization into my site. It works for me and my users. 

Link to comment
Share on other sites

  • 0
On 1/21/2021 at 12:45 PM, imJihyo said:

Hi there @HeyItsDoug! I was looking at Caspio's  system requirements article ->https://howto.caspio.com/system-requirements/#:~:text=Session Cookies,issues filtering data in reports.

and saw that third-party cookies or cross-site tracking prevention settings are related to displaying system messages to notify users of the issue. 

However, since you mentioned you already made sure that your browsers are already accepting cookies and still get this error message in specific times, I can suggest reaching out to Support for further help: https://www.caspio.com/support/

I genuinely hope you finally find a solution for this. :)

 

- Jihyo 

Thank you Jihyo.  I have indeed submitted this to Caspio tech support.

Link to comment
Share on other sites

  • 0
On 1/23/2021 at 4:12 PM, SinJunYoung said:

Hello, just to add, there is actually an option to change the link to get redirected to your own website. For example, I do not want users to know that I am using Caspio so I do not want them to be redirected to the System Requirements. What I did is I created an instructions inside my own site similar to what Caspio had mentioned on this link https://howto.caspio.com/system-requirements/ and I basically just changed the link of the localization into my site. It works for me and my users. 

Thank you SinJunYoung. I have made those changes to the system error message redirecting users to a specific website.

Doug

Link to comment
Share on other sites

  • 0

So Caspio Tech Support assisted me with this error of the 3rd party cookies message displaying on most pages.  As it turned out, in my case at least,  it was the modification of the text itself within the Styles page that was causing this error to appear.  When I reset the customized text back to default from within the Style sheet, the error no longer appears.  It's a bit frustrating as we really need to be able to customize this text and provide a link that takes the user to our instructions instead of the very generic and confusing webpage from Caspio that the default link provides.  

Anyway, just wanted to update this thread.

Thanks!

Doug

Link to comment
Share on other sites

  • 0
On 1/26/2021 at 12:04 PM, LittleMsGinger said:

Hi @HeyItsDoug,

You can also try to remove this warning using CSS. Just paste this code in the Header of your DataPage:

<style>
div[class*="cbSystemMessageContainerContent "]{
display: none !important;
}
</style>

Hope this helps.

 

LittleMsGinger,

I have a similar, I tried your code, it didn't work.  I also tried  the technique of "not customizing texts". 

The 3rd party cookie pop up error still keeps on coming up and keeps on warping (deforming) my login form.

Is there anything else we could do?  I reached out to customer service, opened a ticket, they can't seem to solve the issue.

 

 

 

 

Link to comment
Share on other sites

  • 0

Hi @EmmePGN,

Make sure that third party cookie is enabled in your browser. As per Caspio's system requirements, third party cookies should be enabled for you to use the DataPages properly and to remove the popup warning. Check this link for more details: https://howto.caspio.com/system-requirements/

 

Hope this helps!

Link to comment
Share on other sites

  • 0

Hello LittleMsGinger.

I am fully aware of the requirements by Caspio regarding the 3rd party cookie settings for all browsers.

The issue still keeps on popping up on Safari.   I read somewhere that if you used a styling setup native to Caspio this can be resolved. I tried that too. I made no changes to the resident style "Caspio" for my authentication and for the corresponding html pages.  Still, the pop up happens causing my login form to warp.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...