Jump to content
  • 0

Embedding an iFrame in Microsoft Sharepoint - File or directory not found.


Dayne
 Share

Question

I'm new to Caspio. This is my first app.

I'm trying to build a simple login system for now by deploying my Login html data page to Sharepoint. It only accepts iFrames. The login shows up when I preview it in Caspio.

However when I embed the deployment code it shows me a "File or directory not found." message. 

I've gone through all the tutorials and posts I could find about it here but no luck.

Also I'm a little unclear on how to transition to my dashboard data page afterwards on successful login. All tutorials transition to an html but I want to transition to datapages only for my app.

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0
6 minutes ago, Dayne said:

I'm new to Caspio. This is my first app.

I'm trying to build a simple login system for now by deploying my Login html data page to Sharepoint. It only accepts iFrames. The login shows up when I preview it in Caspio.

However when I embed the deployment code it shows me a "File or directory not found." message. 

I've gone through all the tutorials and posts I could find about it here but no luck.

Also I'm a little unclear on how to transition to my dashboard data page afterwards on successful login. All tutorials transition to an html but I want to transition to datapages only for my app.

Do you have redirection on your HTML datapage? what's your code there? maybe you're using relative path?

Link to comment
Share on other sites

  • 0
26 minutes ago, TellMeWhy said:

Do you have redirection on your HTML datapage? what's your code there? maybe you're using relative path?

Where would I see if I have any redirection? The only code I have is redirecting to a certain page on a successful login.

As soon as I embed the Login html page the error message shows up. No login form, no submit button just the message.

Link to comment
Share on other sites

  • 0
8 minutes ago, Dayne said:

Where would I see if I have any redirection? The only code I have is redirecting to a certain page on a successful login.

As soon as I embed the Login html page the error message shows up. No login form, no submit button just the message.

You're using the iframe deployment right? Error message shows up cause you're probably logged in, try previewing the datapage and logout at the top right, then try on the embedded again. 

What do you mean with Login HTML Page? Is it the same as HTML DataPage? HTML DataPages hold the code

Link to comment
Share on other sites

  • 0
15 hours ago, TellMeWhy said:

You're using the iframe deployment right? Error message shows up cause you're probably logged in, try previewing the datapage and logout at the top right, then try on the embedded again. 

What do you mean with Login HTML Page? Is it the same as HTML DataPage? HTML DataPages hold the code

Ah that's make sense that I'm probably logged in. I'll try that.

So that Login is an html data page that I have an email and password fields that I'm using to login to my app. 

This is the template code inside the html data page:

<script>
if("[@authfield:Admin]" == "Yes"){
window.location = "http://www.mysite.com/admin.html";
}
else if ("[@authfield:Manager]" == "Yes"){
window.location = "http://www.mysite.com/manager.html";
}
else{
window.location = "http://www.mysite.com/employee.html";
}
</script>

Just checks what role the person trying to log in has and redirects them to a specific page. Now I'm trying to redirect them to a datapage in my Caspio app instead of an html on successful login. I'm not sure how to do that.

Link to comment
Share on other sites

  • 0
16 hours ago, TellMeWhy said:

You're using the iframe deployment right? Error message shows up cause you're probably logged in, try previewing the datapage and logout at the top right, then try on the embedded again. 

What do you mean with Login HTML Page? Is it the same as HTML DataPage? HTML DataPages hold the code

So I checked on the html page preview and it shows the error message and the logout button is grayed out so I'm not logged in. 

Link to comment
Share on other sites

  • 0
4 hours ago, Dayne said:

So I checked on the html page preview and it shows the error message and the logout button is grayed out so I'm not logged in. 

Do you have any redirection here? Maybe you're using a Link with relative path checked in any of these, especially the Designated Entry Page under Timeout and Redirection.

image.png.6d8d3a8c729b1e21a189db40b25311d1.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...