Jump to content
  • 0

Datapage Gallery View - Not displaying properly on a iPad


CoffeeLover
 Share

Question

Hi All,

I have several Datapages using Datapage type Gallery View. They work fine on PC (shows the 2 columns) and works fine on mobile (only shows one column). On PC it adjusts perfectly to the size of the screen on my laptop and PC.

However on my iPad (Safari 14.0) it seems to default to the mobile view and only shows one column. I adjusted the data size so it could easily fit 4 columns but it still only ever displays one column.

I thought it may have been something to do with Webstarts and the embed Datapage option so I also ran the Datapage from the direct URL and it still only displays one column. All my Datapages have Enable responsive selected and I don't have any custom code in my Datapages (eg HTML blocks etc).

Do I need to adjust any settings in my Datapage Select Style? Could it be a setting on my iPad causing the issue?

I am really stumped as to why it won't show multiple columns on the iPad.

Any suggestions?

Kind regards

CoffeeLover

 

 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi @Meekeee,

Thanks for the documentation. I am still having no luck in getting columns to display on the iPad.

I made a real simple Datapage 3 columns wide which display fine on PC. But on the iPad I still only see 1 column.

I even downloaded Chrome for my iPad but that is doing the exact same thing and only displaying 1 column.

Is there a .cb command to set number of columns? I can't find that anywhere under Styles? I think Styles is just for CSS?

I am at an absolute loss as to why I can't get multiple columns on the tablet for a Gallery View Datapage. :angry:

Kind regards

CoffeeLover

Link to comment
Share on other sites

  • 0

Hi All,

Just an update...

I have just spoken with the Caspio support team and Tablet views are treated the same as a mobile device.

"The browser's on the tablet is still being considered as a mobile platform thus triggering the responsive function. As mentioned, you may want to try disabling the responsive function on the datapage to make the page appear on mobile as it was on PC browsers".

If I disable the responsive function on the Datapage then all mobile phones won't be able to use the App as the display would be to large.

Support did say they could write a custom script to fix this but obviously that would require $$$.

Kind regards

CoffeeLover

 

 

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...