Jump to content
  • 0

Why Values cannot be submitted due to a data restriction


innov2e
 Share

Question

I have a for_students table and when I add a record from the CASPIO web pages (from the Tables section of my app) I can insert new recors, if i make a Submission Form Data Page I got the terrible message Values cannot be submitted due to a data restriction. 

You have to consider that the for_students table:

  1. Has no input Trigger
  2. Has only one unique field named ID that is a GUID
  3. Has two Function fields:
    a. the first put in lowercase the email fiele: Lower([@field:st_email])
    b. the second build the initial psw for the student using firstname and lastname: Upper(Left([@field:st_nome],2))+Upper(Left([@field:st_cognome],2))+'-school'
  4. Has three relationships as parent with three differents tables: Attacchments, Valuations and Subscriptions
  5. The datapage has non formula or parameters or anything complicated. It ghe the input for: Name, surname, email, phone, State, department, kind of student

I tried:

  • to build a different datapage - same error
  • to check for all three dependecies if there were broken childs
  • to follow hints fromeitherand

What make me crazy is that adding manually from CASPIO web interfaces all works fine! What can be the different behaviour adin from datapage?

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

How about formula fields or calculated values?

You may want to check if you have a formula fields there which the formula used has conflicts with the value on the actual field.  There can be multiple reasons for it but the common one is division by Zeroes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...