Jump to content
  • 0

Images on Caspio placed into HTML block


mhowell
 Share

Question

6 answers to this question

Recommended Posts

  • 0

Try to add the following in an HTML block of a details page:

dpImages.asp?appkey=XYZ&file=[@field:FIE

Replace XYZ with the appkey of the DataPage. Also, make sure that the image field is included in the details but configure it so that it does not show up. You can do this by enabling advanced feature for the DataPage and going in the Advance tab when configuring the details page.

Link to comment
Share on other sites

  • 0

So I tried the solution below but it does not display the image, I had to the the "\" operator to the field, otherwise it was displaying the caspio name for it, and as html it only displays the actual filename and location.

<tr>
            <td rowspan="4">[@field:provider_info_ProviderPhoto\]</td>
            <td>
            <h3>[@field:provider_info_FullName]</h3>
            </td>
            <td></td>
            <td>
            <div style="color: #00bfff;"><i class="fa fa-phone"></i></div>
            </td>
            <td width="20%">[@field:provider_location_Phone]</td>
        </tr>

this is what is have, it is displaying the other fields and icons fine,  just will not display the image.

 

I also tried the "appkey" solution mentioned before with no, I am not sure I understood entirely what to do though. Thanks for anyones help if you are able to.

 

-B

On 1/15/2019 at 10:50 AM, Meekeee said:

 

Hi @mhowell,

You can set it as App Parameter and choose the File type. On your HTML Block, choose the image icon.
 

and configure the Image Properties

image.png.6b24c32ebd4bb4983eec4ca76b8b451d.png

 

I hope this helps!

 

Link to comment
Share on other sites

  • 0
11 hours ago, BRandonH said:

So I tried the solution below but it does not display the image, I had to the the "\" operator to the field, otherwise it was displaying the caspio name for it, and as html it only displays the actual filename and location.

<tr>
            <td rowspan="4">[@field:provider_info_ProviderPhoto\]</td>
            <td>
            <h3>[@field:provider_info_FullName]</h3>
            </td>
            <td></td>
            <td>
            <div style="color: #00bfff;"><i class="fa fa-phone"></i></div>
            </td>
            <td width="20%">[@field:provider_location_Phone]</td>
        </tr>

this is what is have, it is displaying the other fields and icons fine,  just will not display the image.

 

I also tried the "appkey" solution mentioned before with no, I am not sure I understood entirely what to do though. Thanks for anyones help if you are able to.

 

-B

 

I believe it's / not \

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...