Jump to content
  • 0

Document template custom value not working


Wikiwi

Question

I found a bug in document generation's custom value feature. In their how-to documentation it says that you can use data source fields as parameters in custom value mapping type. I tried copying the example provided in the how-to link: (https://howto.caspio.com/document-generation/mapping-templates/mapping-one-template-field-with-many-table-fields-through-parameters/#:~:text=Steps to map a template field with many table fields%3A) But I got the following result on my end:

image.png.78ef14bce062c3d72d9d41f4e2e24310.png

image.png.c8de9bb137364fb2736a471dc8c2939c.png

 

Instead of acting as a parameter, the custom value treats the parameters as actual text 😂😂😂

Things I tried so far that didn't work:

- encapsulating both parameters in single or double quotes

- Used table as a datasource instead of view.

Note: I know I can make a formula field in my table and combine these 2 fields then use that formula field for mapping but what if I'm using a View and I need to map a textbox with 2 fields from different tables?

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello,

That feature works fine on my end. Are you manually typing the parameters, or are you using the "Insert Parameter" button? It looks like if those parameters do not exist, so it is just inserting it as text due to that. If that does not work, I would suggest you to contact with Caspio support team to check it out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...