Jump to content
  • 0

Trouble Styling Basic Data Fields In Search Results



I'm trying out Caspio for the first time and having a problem with styling the basic data fields on a simple results page.  I've even put wild colors into every styling attribute I could find in hopes of finding the one I need to change - but so far no luck.


If you look at the attached screenshot of my results page, you'll see what my problem is.  This is a test application I started to learn Caspio.  It finds which restaurants are available based on a set of choices.

You'll see that I've successfully applied a style to the restaurant name (under "record actions" for some reason), but the other data fields are small and grey, as if I want the viewer to ignore them.


My style settings for "data" on both the search page and the results page don't seem to have any effect here, and I'm stumped.  So, my question is:  where can I enter style attributes for these particular fields?






Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi Jan, thanks for taking a look at this.
I edited my second post (above) to make it a bit more clear.

I generated styles by going to the Styles menu and making a copy of the default Caspian which I then named TEST.
In TEST I chose a variety of colors for the different field types, labels, etc.  Then I connected TEST to my datapage via the checkbox on the styles form.

To answer your question I've now gone back to the TEST style and changed the color of Results Page - Data to green+bold and saved it.
Here is what I'm seeing now in the results page data fields:

1)  Live webpage with embedded caspio code ---  Bold Green
2)  Live webpage with caspio IFrame code --- Tiny Grey
3)  Datasheet preview function ---  Slightly larger Grey
4)  Stylepage preview function ---  Bold Green

Obviously I have a workaround now:  preview only on the style page, and avoid the IFrame deployment, but I'm usually alot happier when things work they way I expect them to.

Link to comment
Share on other sites

  • 0

Hello Martin,


Thanks for your answer! Perhaps it is a bug.


But it seems, you can fix it by yourself:

Edit your Style, select Table Layout element, and click the Source tab.

Find the Style ".cbResultSetTableCell" and delete the line with color.


I hope it helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...