Jump to content
m2367

Wordpress Issue With Default Borders Or Outlines Showing Up, Is This An Issue With All Wordpress Caspio Sites?

Recommended Posts

Hi,

I am going crazy with some grey lines now that I'm trying to launch. I ignored them since I thought it would be easy to fix once I came back to them. Boy, was I wrong. I do not know CSS much at all, so I'm sincerely hoping someone knows a fix. 

 

Thin grey lines surround and are inside all of my datapages. I write boxes below, but they're really lines.post-17048-0-65256400-1417029009_thumb.ppost-17048-0-53513600-1417029068_thumb.p

 

I am deployed on Wordpress, so I've gone about trying to eliminate what is causing them. I now believe this is related to some sort of default style with Wordpress, but not related to something defined in the actual CSS file since I've been deleted files and still having issues. I find it cannot be fixed with Caspio style, however, something in the Caspio code IS triggering these lines.

 

I have included screenshots, look for the thin grey lines, perhaps related to Caspio using tables in its code?

 

Based on various support pages elsewhere, it might be an outline and not a border. Trying to fix that didn't help.

 

I am using Divi from Elegant Themes. It is not an Elegant Themes issue, since I tested with the theme twentythirteen.
 
My site is at adjectivs.com.
 
 
NO BOXES
In Dreamweaver, completely new blank page, no CSS, embed the data page, NO boxes
with iframe, no boxes appear  
With preview within Caspio generated preview, no boxes appear
 
 
WITH BOXES
Used Twentythirteen theme and the boxes appeared.
deleted the whole css and rtl css files for twentythirteen and boxes appeared
deleted the caspio plugin and boxes still appeared, then embedded and boxes appeared
tried adding css to make outlines and border of div gone

 

post-17048-0-53513600-1417029068_thumb.p
post-17048-0-65256400-1417029009_thumb.p
 
post-17048-0-42566300-1417029666_thumb.p
 

post-17048-0-34307000-1417029254_thumb.p

Share this post


Link to post
Share on other sites

Hi m2367,

 

Can you edit the "Style.css" file? Its relative url from

 

If I understand correctly, you can find the ".entry-content table" class and change the 

.entry-content table { border: 1px solid #eee; margin: 0 0 15px 0; text-align: left; width: 100%; }

to

.entry-content table { border: 0px solid #eee; margin: 0 0 15px 0; text-align: left; width: 100%; }

 

I hope, it helps.

Share this post


Link to post
Share on other sites

Hello Mike,

 

If I understand correctly, in your "style.css" file there is the

/* Tables

--------------------------------------------- */
Section, it is around line 450.
 
You can delete or comment:
border-top: 1px solid #ddd; setting in td class and
border-bottom: 1px solid #ddd; setting in tbody class.
 
I hope, it helps.

Share this post


Link to post
Share on other sites
4 hours ago, Pulford said:

How do I get to style.css? I am using a godaddy wordpress template.

 

Thanks,
Mark

Hi Mark,

You can edit style attributes in Appearence-> Editor in Word Press account. If you need to edit Style in Godaddy site builder, you may find instructions here

Hope that helps

Share this post


Link to post
Share on other sites
17 hours ago, DoDoTwin said:

Hello Mathilda,

 

I have the same issue on my website (http://k2t.twinsummits.com)

I have some ugly lines around the elements. I have "Grow Pro" theme.

I also haven't .entry-content table and it seems that it's not just on the tables.

Thanks

Dorian

 

 

 

Capture.JPG

Hello Dorian,

Since the datapage is authenticated I can only check the login page. To remove borders, insert the following code in the header of the datapages and authentication:

<style>

#caspioform tr { border: none !important; }

#caspioform td { border: none !important; }

table { border: none !important; }

</style>

 

Also I would recommend editing theme in wordpress and deleting "margin" attribute for "table" element. 25px value adds space between elements.

You may also use dev tool in your browser (F12) to find other attributes which you need to edit. This article might be helpful 

Share this post


Link to post
Share on other sites

I was able to get rid of the borders through the style in Wordpress, but now you can't really see the text field borders, so it's hard for a user to know where to click to fill in a field. 

 

Update:   I think I fixed it by editing the  style for the data page and adding a color for the background of the fields 

 

Thanks! 

Share this post


Link to post
Share on other sites

Ok, so I was able to eliminate the borders through Caspio headers, but I cannot find a way to eliminate the padding. I have tried working within the wordpress divi theme and eliminating margins/padding, but it has no effect on the way the forms are deployed.

padding.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...