Jump to content
kpcollier

Custom Link/Button - This Site Can't Be Reached

Recommended Posts

I'm trying to make a custom popup button for my datapage. I used the same button in another app, but with a different destination, that works. The destination for the popup is a Details DataPage. It is created like a letter, with parameters from the button filling in many blanks. 

Before, I was using <button>, but upon clicking, it would just take the current page back to the beginning search box. I then changed it to an anchor tag. The a tag created a popup - however, the datapage didn't show up. I get a connection error saying I can't even connect to Caspio.com. 

The DataPage is enabled and I checked the URL like 10 times in my button destination. 

<a class='proposalbutton' href='#' onclick='window.open("http://https://c3eku680.caspio.com/dp/e7505000-----------?Quote_Number=[@field:Quote_Number]","mywindow", "menubar=1,resizable=1,width=500,height=500")'>Proposal</a>

 

Capture54.PNG

Share this post


Link to post
Share on other sites

I think it would be better if you can create a test datapage and check if that will work. If the replicated page works, then there is something wrong with your URL in your original link. Re-deploy and re-paste the URL of the deployed DataPage. Hence, if the replicated Datapage still does not work, check your HTML code. 

Share this post


Link to post
Share on other sites
On 6/26/2019 at 8:45 AM, kpcollier said:

I'm trying to make a custom popup button for my datapage. I used the same button in another app, but with a different destination, that works. The destination for the popup is a Details DataPage. It is created like a letter, with parameters from the button filling in many blanks. 

Before, I was using <button>, but upon clicking, it would just take the current page back to the beginning search box. I then changed it to an anchor tag. The a tag created a popup - however, the datapage didn't show up. I get a connection error saying I can't even connect to Caspio.com. 

The DataPage is enabled and I checked the URL like 10 times in my button destination. 


<a class='proposalbutton' href='#' onclick='window.open("http://https://c3eku680.caspio.com/dp/e7505000-----------?Quote_Number=[@field:Quote_Number]","mywindow", "menubar=1,resizable=1,width=500,height=500")'>Proposal</a>

 

Capture54.PNG

Hello @kpcollier,

 

You have a typo error on your URL Scheme. Semicolon ":" is missing. Make sure that your URL starts with https://

Good thing I have good eyes. Lol. Apologies for being vain.

 

Happy Hacking!

-DN31337

Share this post


Link to post
Share on other sites
5 minutes ago, DefinitelyNot31337 said:

Hello @kpcollier,

 

You have a typo error on your URL Scheme. Semicolon ":" is missing. Make sure that your URL starts with https://

Good thing I have good eyes. Lol. Apologies for being vain.

 

Happy Hacking!

-DN31337

Lol, thanks DN31337. My eyes suck. :lol:

Buuuuut your comment made me notice I'm trying to use two different protocols for one URL. Optometrist, here I come.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...