Jump to content
  • 0
glissando

Wordpress Deployment Overrides Caspio Settings

Question

Dropdown Listboxes are  configured in Caspio to show 5 rows before scrolling is required.  Wordpress deployment only shows the first row before scrolling is required. 

This makes for an undesirable user experience and any help fixing it would be greatly appreciated. I prefer a solution that does not require using iFrames.

Top image is the Caspio configuration. Lower image is what it looks like on Wordpress.

image.thumb.png.c716d415c90e70f69d6f70e16e38f8fa.png

Thanks

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hello @glissando,

 

You may try adding this style in the Header of your DataDage configuration (HTML Editor disabled from the advanced tab).

<style>
  
  select[multiple] {
    height: 100% !important;
  }
  
</style>

Note: If the form element is a Listbox, Setting the height to "100%" will follow the rows specified in Caspio(shown below). You may opt to set this value to a fixed value such as "100px" so your Listboxes are of uniform height.

image.png.3cfd138cbf69a82cf7323a8cdda2a174.png

 

Hope this helps.

 

-DN31337!

Share this post


Link to post
Share on other sites
  • 0

In addition, if you wish to dynamically set the height of the listbox, you may add the code below on the Footer of your DataPage (HTML Editor disabled from the Advanced Tab).

 

The pre-requisites for this to work is that the CSS rule posted above is in your header, and that the "Allow multiselection" option is checked OR with some JavaScript, you have set your dropdowns to allow multiple selection.

 

<script>

document.addEventListener('DataPageReady', function() {

  document.querySelectorAll('select[multiple]').forEach(function(elem) {
	elem.size = elem.length;
  });

})

</script>

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...