Jump to content
  • 0

Google Map Mashup Set-Up with Casio URL Deployment


jbloome
 Share

Question

Hello,

I've followed all the instructions for the Map Mashup Deployment but am stuck how how embed the Map Mashup code in the datapage above any webpage deployment code.  I am using caspio servers to host my site and am not embedding it on any website.  When I go to the deployment code I see no way to paste the required Map Mashup code.  Please advise. 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Howdy All,

My Google Maps finally work and after two days I have an answer to my question which you might find useful.  

1) I don't use a webpage so my deployment method is URL in Caspio's servers.  

2) Search for Google Cloud API console and sign up for a billed API account (I had a free account and didn't realize I had to have an API attached to a billed account).  I think with the billed account the free Map View limit is 28,000 inquiries/month before incurring expenses.

3) Start a new project through the Google Console and get your API code for your billed account.

4) On your Google Cloud API account search the API library and Enable the API for Maps Javascript API and Geocoding. 

5) On the map mashup select the search and results table from where you are pulling data not the datapage where you might have the map mashup (e.g. my maps search datapage pulls data from my homes_table, in this case I would choose the homes_search and results datapage pulling from the homes_tbl not the maps search and results datapage).  

6) Make sure you add your own customized field (e.g. in addition to city, state, zip my Address field is called Address1 and I had to add this field to generate the proper code snippets which included Address1 not Address which is the default). 

7) For the map mashup the first code snippet "before the webpage deployment" goes into a header for the Configure Results Page Field.

8) The 2nd code snippet goes in a HTML block(make sure that it is at the bottom with  no other fields below it) on the Configure Results Page.

9) The 3rd code snippet goes in a HTML block (make sure that it is at the bottom with  no other fields below it) on the Configure Details Page.  

10) On your Datapage Data Source page uncheck Responsive, go to Your Results Page and uncheck all the editing options, go back to the Datapage Data Source and check disable AJAX loading.

That should work!

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...