Jump to content
  • 0

Trigger was working but somehow moved around


biota
 Share

Question

Hi all

One of Caspio team directed through setup of a trigger, as I can't seem to decipher the process : /

Anyway, it was working fine and then stopped. When I looked at the trigger, it had become 'unpluggd', with parts moved around. I've tried to set it back how it was but i just can't get it to validate. 

I suspect it was  intially broken by me changing table and field names? However I subbmitted  a ticket yesterday and one of the C team told me they fixed it, but it does not work for me and again you can see a part that looks unplugged, over to the right.

I have table with column 1 set to autocomplete from a lookup, and the Triggger populated further fields from the lookup to the table. There is relationship set between the PK/FK only. 

Would anybody be able to guide me as to what's up here? I think the #instered term throws me a bit, and there's something I'm just not getting. 

TIA  

image.thumb.png.5822a238115f44f84602febe6587a630.png

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi @biota,

#Inserted is the data that is being inserted to the table. Please see the following:

https://howto.caspio.com/tables-and-views/triggered-actions/

In your case, when you insert new record to the table, it will look it the 'Sources_lkp' table, and find if there are record that has the same 'source_name' as 'historical_feature_name' from your inserted record. It will than populate fields 'Source_ID', 'significance_site' and 'contaminants_site' with values from the selected fields from 'Sources_lkp' table with that same 'source_name' as 'historical_feature_name'.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...