Jump to content
  • 0

Caspio & Wordpress SEO deployment error


pgorrell
 Share

Question

I keep receiving this error across all data pages when deployed with SEO. I have Exec PHP set correctly and have installed the caspio plugin installed and activated. It obviously is trying to send header info after the header file has been called. I am using inline deployment and have also tried installing the information in the header file via external deployment. Any Ideas?

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/geocentr/public_html/local/wp-content/themes/pixel/header.php:7) in http://b4.caspio.com/scripts/dpload.txt on line 11

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/geocentr/public_html/local/wp-content/themes/pixel/header.php:7) in http://b4.caspio.com/scripts/dpload.txt on line 11

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I included a php.ini file and it reads:

allow_url_fopen = On

allow_url_include = On

I included it in the root file and that is how I got this error. Previously I was getting:

Warning: require_once() [function.require-once]: URL file-access is disabled in the server configuration in /home/geocentr/public_html/local/wp-content/plugins/exec-php/includes/runtime.php(42) : eval()'d code on line 2

Warning: require_once(http://b4.caspio.com/scripts/dpload.txt) [function.require-once]: failed to open stream: no suitable wrapper could be found in /home/geocentr/public_html/local/wp-content/plugins/exec-php/includes/runtime.php(42) : eval()'d code on line 2

Fatal error: require_once() [function.require]: Failed opening required 'http://b4.caspio.com/scripts/dpload.txt' (include_path='.:/usr/local/php52/pear') in /home/geocentr/public_html/local/wp-content/plugins/exec-php/includes/runtime.php(42) : eval()'d code on line 2

Link to comment
Share on other sites

  • 0

Hi,

We have had customers experiencing same issue.

In some cases it was a hosting issue; customer contacted the hosting company and they fixed the issue by enabling "output_buffering" on.

I recommend if you contact the hosting company and if the issue still remains then you can try the second solution:

The line of code below must be the very first line of code in the whole file. If your file is an HTML/HTM file, save it as php and paste the following code in the first line of the file.

<?php session_start(); ?>

Please share your experience with us whether the solutions above solve the problem or you find another solution in your case.

Best,

Bahar M.

Link to comment
Share on other sites

  • 0

If this is the case, I am thinking your hosting company might not be able to allow a third party hosted php file access. Here is the scenario:

Caspio PHP deployment code includes a file “dpload.txt” which hosted on Caspio servers. Some hosting companies do not allow include file on shared hosting environment. Here is a response from the host company regarding same issue:

“Your script calls a remote URL which requires allow_url_include to be enabled.

However, for security concerns, we do not support allow_url_include on shared hosting environment. Please simply upload the text file to your server and access the file locally to get the file contents.”

Solution:

CURRENT DEPLOY CODE (assuming external style)

<?php require_once('http://b4.caspio.com/scripts/dpload.txt');dpload('http://b4.caspio.com/','appkeyhere','l');?>

NEW SUGGESTED METHOD

Load http://b4.caspio.com/scripts/dpload.txt in a browser and save the content as a file on your server. Then refer/load that file in your PHP file, before you load the code below

<?php dpload('http://b4.caspio.com/','appkeyhere','l');?>

Remember to replace 'appkeyhere' with the key from your deployed DataPage.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...