Jump to content
  • 0

Automatic Emails & Views


DBAngel
 Share

Question

I have a web form that relates to a view and have it set up to send me an automatic email when the form is submitted.

I'd like the automatic email to say:

NAME is scheduled to be interviewed on DATE at LOCATION, ADDRESS.

NOTES ON NAME

The NAME, ADDRESS and NOTES fields all come from a table of contact info.

The DATE and LOCATION come from a table of interview info.

These two tables are connected in a view where the interview table is editable. Both tables are connected through a unique ID.

The email I'm getting says this:

is scheduled to be interviewed on 2/13 at their office, .

All the info that should be coming from the contact info table is missing. Am I not able to get this info or is there something I can/should be doing differently?

Cheers for reading & any advice.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

To Insert fields in the Subject or Message body, place the cursor at the appropriate position, select the field from the Insert fields dropdown and click the Insert button. The insert field should look like: . Please note the fieldname is different between a Table and a View. It changes to ViewName_TableName.FieldName in the View. You can check the name of the field in the View. Please use the Insert button to add the field name.

Regards,

Fangjie

Link to comment
Share on other sites

  • 0

I used the drop-down box when creating my email. I have the issue of one half of the view not giving me info, regardless. As an example, I changed the email and just tried to get the ID field from each one of the tables and this is the email I got:

ID from Interview Info Table : 182

ID from Contact Info Table :

I also tried to change the fields to include the view name (e.g., and that just sent me an email where I could see the code, but no data was included.

Link to comment
Share on other sites

  • 0

The auto emails from submission form cannot access the records that are inserted by joins in view at that moment. It can only access the records that are inserted by the forms. Therefore, it will be received blanks instead of respective values. The options for including fields from view in email should not be present.

You can create a submission form without auto emails, and link direction after records submitting to a new Update Form. The Update form is based on that View source. Insert JS code below to update the records automatically when page loading.

<script>
function f_submit() { document.getElementById("caspioform").submit(); } 
window.onload = f_submit; 
</script>
Please add automatic emails in this Update Form. All the record will show in the receiving mails.

Regards,

Link to comment
Share on other sites

  • 0

Here is the instruction steps:

1. Create a new Single Record Update DataPage

-------- choose the same View as the data source, enable Advanced Options and parameters,

-------- check "Find record through unique ID" and insert a unique field of the View,

-------- In the Select Field screen, choose any one field for updating,

-------- In the Configure screen, create a HTML Block, and insert the previous code for auto submission the update form,

-------- In the Destination and Trigger screen, check the Automatic Emails Options checkbox,

-------- In the Email Options screen, fill all the fields same as the existing submission form.

2. Edit the existing submission form

-------- in the Configure screen, highlight the unique field which you select for updating, click Advance tab, and check "pass this value to next page",

-------- in the Destination and Trigger screen, uncheck both Automatic Emails Options checkbox, select "Go to a DataPage" from Destination after submission dropdown box, and then choose the previous Single Record Update DataPage as the destination.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...