Jump to content
  • 0

Autocomplete not possible with a field that is not an ID


Paolo
 Share

Question

Hi everybody,

I'm trying to create a form to insert data into my appliances table. I would like to use appliance_types table as a lookup table in a dropdown box. That is not a problem. The problem is when I try to use Autocomplete. It seems not possible to use autocomplete on the ApplianceType field (text) rather than on the ApplianceTypeID. Any workaround? Thank you so much :).

Tables.PNG

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 1

Hello @Paolo,

If I understood you correctly, you try to use Autocomplete for the ApplianceTypeID field (like shown on the screenshot below).

jRl4Ugl.png

 

Since you are going to submit data to the appliances table, it is not possible to submit Text (ApplianceType) to the ApplianceTypeID field due to the data type compatibility.

Please try the following workaround.

1) Add the Virtual field to the Submission form. This will be the AutoComplete field. 

qu8mEG6.png

 

2) Set the ApplianceTypeID field as a Calculated Value

EQxt6bg.png

SELECT ApplianceTypeID FROM appliance_types WHERE ApplianceType = '[@cbParamVirtual1]'

 

Double-check your fields and table names.

3) Hide the Calculated Value field. Go to the Advanced tab and check the "Hide Field" checkbox.

 

Maybe someone else will suggest another workaround :) Hope, this solution works for you. 

 

Link to comment
Share on other sites

  • 0
16 hours ago, CoopperBackpack said:

Hello @Paolo,

If I understood you correctly, you try to use Autocomplete for the ApplianceTypeID field (like shown on the screenshot below).

jRl4Ugl.png

 

Since you are going to submit data to the appliances table, it is not possible to submit Text (ApplianceType) to the ApplianceTypeID field due to the data type compatibility.

Please try the following workaround.

1) Add the Virtual field to the Submission form. This will be the AutoComplete field. 

qu8mEG6.png

 

2) Set the ApplianceTypeID field as a Calculated Value

EQxt6bg.png


SELECT ApplianceTypeID FROM appliance_types WHERE ApplianceType = '[@cbParamVirtual1]'

 

Double-check your fields and table names.

3) Hide the Calculated Value field. Go to the Advanced tab and check the "Hide Field" checkbox.

 

Maybe someone else will suggest another workaround :) Hope, this solution works for you. 

 

Thanks a lot @CoopperBackpack! I will try this for sure. You are a genius!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...