Jump to content
  • 0

Data Page Authentication Filed not Available


Question

I have a 2 part data page for a  global Admin, that Page 1 creates a new Org (Customer) in an Org Table and will assign a RandomID at time of creation with an end destination of Page 2 where it hands the Org_ID to Page 2.

Page 2 will create a single Admin User for the Org (Customer) in a Org User Table. This admin user is stamped with the related Org_ID created in Page 1 identifying what Org they belong to.  This works like a charm without issue. I have a new record in my Org Table with a unique Random ID and a new record in my Org User Table for the newly created admin, and they are given the Org ID (text 255 data type) from the Org Table.

I have a 3rd data page that is a  Submission Form data page that allows the newly create Admin User in the previously described data pages to create new users for their Org. Data Source is the Org User Table. This is restricted access for only admin user. This is where my problem is.

1) If I configure it to on load, receive: Authentication Fields - I do not have my Org_ID as an option in the dropdown.

2) If I configure it to on load, receive: External Fields - [@InsertRecordOrg_ID] it adds the last ORG_ID parameter in the last session (Or prompts me for it) , which is not right. 

There can be multiple Orgs (Customers) each having their own Admin(s) which are created with the appropriate ORG ID they are related to (Page 1 and 2 above). So when my new user is created, it needs to have the right ORG ID based on the Admin that create it. 

I believe option 1 is the right way, but why do I not have my ORG_ID as an options for an authentication field?

 

image.thumb.png.7df1de9aa6dabf7e787386571eb30e01.png

 

Thanks

 

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...