Jump to content
  • 0

Issue allowing speakers to view their own seminars


DavidFE
 Share

Question

My goal: Create a datapage that allows speakers to view only the seminars they are speaking for.

Relevant data:
Seminars table fields: SPEAKER_1_ID, SPEAKER_2_ID
Speakers table fields: SPEAKER_ID, CONTACT_ID
Contact table fields (This table is used for authentication): CONTACT_ID

What I thought would work:
I created a view joining the tables.
The view displays all seminars and their related information.
I created a datapage using the view as a source. Without anything limiting the records displayed, the datapage displays all seminars like it should.

I tried limiting the records displayed by user authentication: linking contacts.CONTACT_ID to speakers.CONTACT_ID.
I expected the datapage to then only display the seminars whose SPEAKER_1_ID or SPEAKER_2_ID matched the speakers.SPEAKER_ID that was connected to the contacts.CONTACT_ID for the logged in user, but no records display when I do this.

I am not seeing why this isn't working. If you need more information, let me know. I only wrote what I thought was relavent so far. I figure I'm missing something simple, but hit a dead end trying to figure out what it was, so any ideas are appreciated.
 

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi @DavidFE - you may try to enable the Record Level Security or RLS feature.  This will allows you to restrict access to records based on the current user’s profile data. You may check this article for more info: https://howto.caspio.com/authentications-and-connections/authentication/record-level-security/record-level-security/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...