Jump to content
  • 0

Receive parameters functionality not working



I am trying to pass parameters in the url via a hyperlink from a set of search results to a new submission webform. Here, the fields in the new web form are populated with the data in the fields from the record in the search form. This is basically to allow the end user to copy the record and make changes, if necessary, in the table.

My problem is that over half of the fields in the new submission page are text fields formatted as checkboxes. Now, when I try to Edit the submission form to 'Configure Fields' and click on the Advanced Options, I click the radio button (or checkbox, in the case where the field is formatted as such) for 'On Load: Receive Parameter [@FieldName]' and leave the FieldName the default value. What is weird is that for all of the text fields formatted as Text Field or Text Area (in the Standard tab), I can click this button and then click Finish to save the data page. When the page is opened back up for editing, the parameters are saved as they should be. BUT, when this is performed for the fields where the text is formatted as a checkbox, and saved by clicking Finish, the 'On Load: Receive Parameter' is NOT checked once you re-open the data page for editing. So Caspio is not saving the settings for this parameter setup.

I was testing the deployed page and noticed that the parameters were passed for the text, but not the checkboxes. This is where I went back and found this issue. This is a huge part of the database, so I need to find some type of workaround if this ain't gonna work.

Any thoughts or ideas? Maybe this is a bug?

Thanks for reading - I hope my description at least makes a little sense.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...