Jump to content
  • 0
Sign in to follow this  
AleksandraNoelMcClain

No Records Found?

Question

I've used Caspio over the past few years to create a very simple 'find your supervisor' search box for incoming freshmen to our department. Each year, I import an Excel spreadsheet with the list of student names and supervisors' details into a caspio table. That table then provides the data for a simple Last Name/First Name search box, which returns the details of the student and their supervisor.

 

It's always worked perfectly until just now, when I tried to update it for the new year. Basically, everything stays the same in the report datapage except for the table behind it providing the data. So after importing the new table (which looks fine when I view it--all the information is there, field names are the same as always, etc.), I edit the report, using the dropdown box to tell it to draw information from this year's table. I've done this for a few years now (I've been running this feature since 2010-11), and it's always worked. But with this update, when I preview it or deploy it live, it doesn't work. I'm always getting the response "no records found", no matter what student name I type to test it out. I just went through and switched the report back to drawing on last year's 2013-14 supervisor table, and the search box/report works perfectly again. But when I switch it back to the 2014-15 table, it stops working. I'm at a loss!

As the datapage works with last year's table, it must be something in the new table that's wrong. But I haven't changed any settings except for telling it which table to get its data from. Does anyone have an idea of what might be going wrong? Could it be something with the way I imported it? I've just tried importing this year's Excel file again with a different filename, and it still doesn't work. Any help is much appreciated!

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello Aleks,

 

Can you open your 2014-15 table in the Bridge? Does the data get imported at all?

If you do not enter any name, do you get the same message?

Is it the same Excel or maybe you have used a newer version of it?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...