Jump to content
  • 0

Search Defaults Submission Form


crazedwombat
 Share

Question

Hi,

 

I have a small problem and I think I am too close to the problem to figure it out anymore. I used the Caspio help file to create a same page search submission form with the virtual fields.

 

The search functionality works, however i have a separate form that pulls from a User_Search_Preference table that the user sets. 

 

I am trying to load the preferences when the search form loads (e.g. Drop down of fruit but they selected Apple in their search preference) I need to load Apple as the default on load value. The problem is in On Load there is no default value option, it is either external, auth, or system.

 

How can I prepopulate my search options from the Search_Pref table?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

So I move everything to the authentication field and I'm still having a couple issues with it loading the search defaults.

 

The checkbox fields dont have the option of a authentication on load...can I get away with [@authfield:Loan_Amount_Pref]?

 

Also, even though I'm On loading the drop down menus from the auth fields, it is still not loading it. If I make changes to the search form real time it works fine but it is not loading the preferences from the table 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...