Jump to content
  • 0

Wordpress layout error deploy


alwinoei
 Share

Question

In Caspio when I do a preview (see right photo), the form i designed looks just fine, and without lines.

After deploying the data in Wordpress (see left photo), the layout is completely different with lines etc. and very much not ok.

How to get the exact layout as seen in Caspio preview, so without lines etc.

Current Wordpress version: 4.7.2 (the latest)

Plugin: Custom Database Applications by Caspio version 2.0

What to do?

Screenshot 2017-02-22 23.13.09.png

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
On 2/22/2017 at 2:25 PM, alwinoei said:

In Caspio when I do a preview (see right photo), the form i designed looks just fine, and without lines.

After deploying the data in Wordpress (see left photo), the layout is completely different with lines etc. and very much not ok.

How to get the exact layout as seen in Caspio preview, so without lines etc.

Current Wordpress version: 4.7.2 (the latest)

Plugin: Custom Database Applications by Caspio version 2.0

What to do?

Screenshot 2017-02-22 23.13.09.png

Hi, 

Style of the theme in site builder overwrite Caspio style, since you embed datapage on a webpage and elements of the datapage inherit style attributes from site builder. 

The workaround is to deploy the datapage in iframe (not the best option if you pass parameres or redirect user after submission).

Another option - editing style attributes of theme and removing or editing those attributes which overwrite caspio style. It easily can be found using developer tools in your browser (hit F12 to call dev.tool)

To remove borders, insert the following code in the header of the datapage:

<style>
#caspioform tr
{
border: none !important;
}
#caspioform td
{
border: none !important;
}
</style> 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...