Jump to content
  • 0

Issue importing products into online store app


MattRippon
 Share

Question

I am currently using the test online store app but have come across an issue when trying to import the products file into the ECM_Item table. In my import file I am leaving both the ID and Rand_ID columns blank as these are autonumber and RandomID respectively. However, the step before import shows both these columns as Text (255) and when I import I get an error message stating that the Field_ID is blank. It then  created a new category table but with list form your demo store.

 

Any ideas?

 

Many thanks

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0
2 hours ago, MattRippon said:

Hi, please see attached

 

Have you tried deleting the ID rows on your import files before you import them?

I believe the upload system is thinking that you are setting the ID fields to the imported records as null or blank, which is against the rules for Random ID/Unique values. 

Try deleting these columns completely when you import your records, and the ID fields should automatically get a value in the Caspio table.

Link to comment
Share on other sites

  • 0

@MattRippon Did you choose the Append option when aligning your source object to your destination object? This looks like you used the 'Create New' option, which literally creates a new table for the data. Instead, you should select Append for that option and then choose the correct table to import the records to. 

Link to comment
Share on other sites

  • 0

Yep, I used the Append option to do this. The table i wanted updating has worked fine, its just the additional duplicate tables being created. 

For this project i am using a  trial account and have duplicated the online strore for the structure but didn't copy the data.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...