Jump to content
  • 0

Calculation Power()



Good day,

I'm busy with my first project and I have a load of financial calculations to do. One of the calculations is to calculate the future value of an investment.

Future Value Formula

  • Future Value (FV) = PV × (1 + r) ^ n


  • PV = Present Value
  • r = Interest Rate (%)
  • n = Number of Compounding Periods

I use formula fields in my tables to calculate these values=>

To calculate my present value I use the formula:

[@field:nett_income_required_from_pip] / (100 - [@field:estimated_tax_rate_retirement]) * 100

My Interest rate is a fixed vale of 5

My number of compound periods are calculate with this formula:

[@field:retirement_age] - Datediff(year,[@field:dob],[@field:timestamp])


I've tried to write the following formula to calculate the Future value but it returns syntax errors and cant figure this out. Any assistance will be appreciated.

([@field:nett_income_required_from_pip] / (100 - [@field:estimated_tax_rate_retirement]) * 100)*(Power((100 + ([@field:inflation])),([@field:retirement_age] - Datediff(year,[@field:dob],[@field:timestamp]))))

UPDATE: The above formula verifies but when I'm trying to save my table I get the error =>

Unable to save table due to incompatible values in one or more formula fields.
UPDATE: I cleared my table data and it saved successfully.
Net problem now is when trying to submit the data to this table via my form I get the error =>
Values cannot be submitted due to a data restriction.

Many thank


Edited by JacoStander
Problem Solved
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi! For everyone's reference as well, here's what you can check when you get the errors listed above:

Unable to save table due to incompatible values in one or more formula fields

- Make sure no division of 0 will happen 

Values cannot be submitted due to a data restriction

- there are several possible reasons and some of them are broken referential integrity in relationships, empty formula field values or fields used in formula fields are not of the same datatype, or corrupted table/datapages





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...