Jump to content
  • 0

Datasheet does not sort


Tryeager
 Share

Question

I have seen https://howto.caspio.com/tables-and-views/managing-data/, "Managing Data in Datasheet" and the section "Sorting Data", which shows that datasheets act exactly the way one would expect regarding column sorting.  I've also seen my own datasheets perform exactly that way.   But I don't see it today!   

I've been experimenting for only about a week and have the beginnings of a small database of just three main variables and many-to-many relationships.  But none of my three tables sort when the heading is clicked and no column has an arrow to show the existing sort column.  They did yesterday, though.    

It doesn't seem like it would be related, but I duplicated my database and did some crazy experiments on the new copy.   Then I noticed the columns wouldn't sort.   When I went back to the original, it wouldn't sort either.  

Any hints.  

293992313_Nosortingarrows.JPG.1d400d8198e7976c17dbf30bfa488c66.JPG

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
7 hours ago, Andrew said:

Hello @Tryeager

What do you see when you click the field name?
Does it start moving across the list of fields?

Thank you for replying to my question.

For narrow columns, the field name jumps to the right a little into the next field.  On wider columns, it appears to jump to the center of the column.  

Clearing cache solved the problem.  Please see my reply to AtayBalunbalunan.

Link to comment
Share on other sites

  • 0
4 hours ago, AtayBalunbalunan said:

Hi Tryeager, please try to clear your browser's cache or use a different browser. Also encountered this issue in Google Chrome but when I tried it in Mozilla Firefox, it works.

Thank you for replying to my post.

I have had this problem twice in a short time, and the problem affects all apps, even the physician demo app.

On the first occurrence under Chrome, I went to IE, and it, too, had the problem.   I almost never use IE, and I am certain that I had not even loaded it since the computer had been on that time.  When I went to Firefox, the problem was not there.   Restarting solved the problem for Chrome and IE.

I had the problem yesterday and so went to Firefox to do my work.   Upon reading your post, I checked and the problem was there in Chrome and was there again in IE.   So, guided by your post,  at chrome://net-internals, I cleared my host resolver cache, flushed my socket pools, and cleared my bad proxies.  That solved the problem under Chrome, but I don't know which of the three steps solved it.

On IE, I cleared my browsing history and deleted temporary files and cookies.  That did NOT solve the problem.  Rebooting did solve the problem under IE. 

I'd like to point out that before posting, I attempted to enter a support ticket.  My still being in trial mode, I was passed to sales, and Kevin Batt opened a support connection to my computer and witnessed the problem under Chrome and IE.  He kindly enlisted the support department to follow up with 1 day of free support, and I was led to expect them to contact me shortly.  They never did make any email or phone contact with me, whatsoever, to my disappointment.  Days later, I noticed that they had cloned my app, but I have no idea what they did.  I'm sure they saw normal behavior since it was on a different machine, but I wish they had at least told me that the problem was mine and not Caspio's or something more helpful.  As a non-paying customer, I do not expect free support — except when I'm told I will get it.  Caspio did not follow through on its promise.  Perhaps they could have learned something from my problem so they could improve their software that apparently has some challenges with Chrome and IE. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...