Jump to content
  • 0
Sign in to follow this  
Chuchu

Multiple Lines below deployed report

Question

Hi there!

    I'm using a report with calculated fields on it, the fields are hidden inside html blocks, on Caspio preview stage the report looks perfect, but when i deploy the report on wordpress the report shows the information, but below the "html block" it show more lines below.  Is there a fix out there for this ?  This is happening to all my detail reports using calculated files on hidden html blocks. 

Regards. 

Image example:

image.thumb.png.3c17145f40111113a75bfb5694e72a70.png

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi Chuchu, WordPress style overrides Caspio's, I would suggest adding a Header & Footer in your DataPage, and insert the code below in the Header.

<style>
#caspioform tr { border: none !important; }
#caspioform td { border: none !important; }
table { border: none !important; }
</style>

For more information on how to add Header/Footer in your DataPage, you can refer to this document: https://howto.caspio.com/datapages/datapage-components/datapage-header-and-footer/

Let me know if this works for you. If not, please provide the URL to your deployed DataPage.

Share this post


Link to post
Share on other sites
  • 0

Hi, just to add you need to use none in the style at the same time use !important.

Hiding an element can be done by setting the display property to none. The element will be hidden, and the page will be displayed as if the element is not there (Here is a helpful link: https://www.w3schools.com/css/css_display_visibility.asp)

The !important property in CSS is used to provide more weight (importance) than normal property. In CSS, the !important means that “this is important”, ignore all the subsequent rules, and apply !important rule and the !important keyword must be placed at the end of the line, immediately before the semicolon.

(Here is a helpful link: https://www.geeksforgeeks.org/how-to-apply-important-in-css/#targetText=The !important property in CSS,line%2C immediately before the semicolon.)

I hope this clarifies the CSS styles that use above.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...