Jump to content
  • 0
mgredmond

Change Field Sizes

Question

How do I change the size of a data field? When I leave everything on AUTO, the datapage displays as seen below:

 

image.thumb.png.3605de440c7a8420538b7a416999bd2f.png

The size of the Purchase Date field is way bigger than it needs to be for a date and results in the record pushing beyond the edge of the display area.I have tried changing the field size to a Percent (various) and to Pixels (various), but the field size never changes. 

Any help is appreciated.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
2 hours ago, Vitalikssssss said:

Hi @mgredmond,

If you don`t have any sensative data, can you share with us a link to this Datapage or web-page?

You can restrict the width of the Datapage as explained in this article:

https://howto.caspio.com/styles/fix-the-width-of-the-datapage/

Regards,

vitalikssssss

Thank you, @Vitalikssssss. The article is very informative, but let me add a couple of additional notes and make sure I understand.

The website on which the Datapage is deployed is a Joomla CMS site and the display area is defined in the Joomla template I am using. I guess one alternative would be to try to figure out how to widen the template. But it would be much easier just to restrict the width of the field in question. Is that not the purpose of the Field Size (Pixel or %) setting? If I am mistaken, what is the purpose of this setting? How is it used?

 

Share this post


Link to post
Share on other sites
  • 0

Hi @mgredmond,

Caspio Style has a default settings for the width of the Datapage set to 100% which overrides the field width settings. 

You need to check the width of the container where you placed in your CMS  and adjust width of the Datapage accordingly.

Hope this helps.

Regards,

vitalikssssss 

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Vitalikssssss said:

Hi @mgredmond,

Caspio Style has a default settings for the width of the Datapage set to 100% which overrides the field width settings. 

You need to check the width of the container where you placed in your CMS  and adjust width of the Datapage accordingly.

Hope this helps.

Regards,

vitalikssssss 

@Vitalikssssss, it does help. But not in a good way. Basically, you are telling me that the field width settings are meaningless, since they are overridden by the width of the DataPage. Then why have them? I notice that on the Video Clip in the support area, it shows a CHARACTERS choice in the Field Size setting along with Percent and Pixels, but that has already been taken away in the actual product.

Another peeve of mine: In the screen shot above, not only is the Date Field wider than it needs to be, it is also taller than all the other fields. That presents an ugly look to the user. Why can't there be consistency?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...