Jump to content
  • 0

Grid Edit on filtered list - Error - No Records Found.


Schbal
 Share

Question

Hey! 

I have created a basic table with some basic data, then I created a data page with some filter and grid edit capability, and then the following happened: 

I used the filter and got some data that I wanted to modify. I switched to grid edit mode, then made modifications on a record,  I have modified the data that I used to filter by. Then I clicked out from this row, It saved it successfully. It was still in the grid edit list, even though it no longer met the filter criteria. But I clicked back to this row, to make one more modification on a data, but when I tried to click out to save, it threw this error: No record found. 

1. Filter by Search flag:
 image.png.618ccccb0efab45ccf2d2e339aefc14f.png

2:  Modified and saved the Test row Search Flag to No (Note: Filtered by search flag to be marked):
image.png.82500ea9b8a92e8b9ade02da6ba84ce2.png

3. Clicked back to the second row to modify the Name too. I tried to rename Test to Test1
image.png.ddff80d9dcde0fb22538530b779c0e44.png

4. When I tried to save (with clicking out) I have got the error above. 

Is there any workaround to this problem? Well it looks like a bug to me, and already reported this. But maybe somebody have a trick to this. :)

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello @Schbal,

The result seems to be expected for me. When searched for a record, then modify it, the updated record will not meet the applied criteria anymore. If you try to edit it again on the same grid, it will throw you an error since in the result, it should not be included.

As a workaround, after you modify the record, then if will not meet the criteria, it's better to exit the grid edit option first, then enable it again.

You can also open a support ticket so Caspio's support team can confirm. 

 

:) 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...