Jump to content
  • 0

How to allow Time Format to input


jameswigley
 Share

Question

Hello

I have a table containing some date/time fields which i need to have time recorded ( such as 09:30) for a timesheet application

I have modified my localisation file and set Date/Time Output Time to Custom Format HH:mm

However in the datapage is I try and enter 09:30 I get the message: Must be a date -idiot! ( I added Idiot to the localisation field to prove that it is being referenced)

What am I not understanding??

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

That's right. The localization is for custom display purpose but not for the data entry. A Date/Time field can store either Date or Date plus Time but it can not store Time only. This is a feature we can add to the list for future considerations. For now if you would like to only store time you can choose text 255 however you will lose chronological sort capability.

Thanks,

Bahar M.

Link to comment
Share on other sites

  • 0
Link to comment
Share on other sites

  • 0
On 11/26/2018 at 9:30 PM, Meekeee said:

They need an option to remove DATE from the drop down / calendar option . SO many steps just to get a simple field to enter time of day.

Link to comment
Share on other sites

  • 0

Hi! Would also like to share this since I had problems with my form since I want to only enter a time value. The thing is, looks like it's Caspio's requirement or general field value requirement for Date/Time fields to have a value in this format: MM/DD/YYYY HH:MM:SS

I noticed we can enter a date value only and have the time as 00:00:00 by default. However, since we cannot set the date value to blank or 00/00/0000, we need to include a date value at least. What worked for me is I used a standard date, like January 1, 2000 for all my values that only needed time. Another option is to just use a text field  “¯\_(ツ)_/¯

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...