Jump to content
  • 0

Triggered Action Showing old Values



I am trying to run a triggered action to update a table with the new values that I have just input, but the way I have my triggered action set up is returning the value that was present before the update, rather than returning the updated value. 

In more detail, I am creating a performance evaluation program. Each employee in my database will have competencies they are assessed on (for example, Accountability) and each competency has a definition to go along with it. In one table, I am housing all the competencies and their definitions. In the other table, I have an employee database that will include the competencies and their definitions that are specific to that employee. I would like this to operate such that if I make a change to a definition on the table housing the competencies, that everyone with the matching competency has their definitions update via a triggered action. When I update my definitions currently, the triggered action is inputting the current definition (before the revisions) rather than the revised version of the definition.

Could anyone help me to resolve this issue? I have included a screenshot of my current triggered action below. The "Organization" columns house what group each competency and definition belongs to; the "Q1_Value" column houses the first competency for that specific employee; the "Competencies" column houses the list of the individual competencies on the table with the definitions.

If it is helpful, I ran into a similar problem previously and was able to get it resolved (with the help of this forum) by using a table variable. I tried that approach with this, but continued to have the same issue.

Any help would be greatly appreciated!


Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

@NiceDuck This was created on a table called 'PT_Competency_List_1,' and is set up to trigger an update on the 'PT_Performance_Evaluation_1' table. Not sure that it matters, but the 'Definition' fields in both tables are Text (64000), and the 'Q1 Value' and 'Competencies' fields are both Text (255). Please let me know if there is any other information that would be helpful to provide.

I have continued to test and tweak the trigger but keep getting that same result. Any other ideas of what I could try?

Link to comment
Share on other sites

  • 0

Hi @NiceDuck,

Thanks again for working to help me with this! It turns out this action was being caused by a different triggered action on another page. So this one was functioning properly, but that was triggering another action which was overwriting it with the old definition. Not great that I overlooked that, but I am glad I was able to get it resolved. Thanks again!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...