Jump to content
  • 0
Sign in to follow this  
gavinoff

Map pop-up

Question

I created a page that maps specific locations. But when you click "map it" and the pop-up box appears, the box is not big enough and some of the information meant for the pop-up box bleeds onto the map. Is there an easy solution? Thanks.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
[@field:Description]
is the part of the code that controls the data in the map. You can also make the whole map bigger in these two lines:

500

500


If it did not help and if it is ok for you, provide the URL of the map to see if there is any workaround. :wink:

Share this post


Link to post
Share on other sites
  • 0

Thanks for the suggestion. I still couldn't get the info box to match the size of the info. Here's the URL if it helps.

http://www.charlotteobserver.com/2011/0 ... north.html

Type in "auto" under station name and then click "map it" for any record. You'll see the words run onto the map. Thanks again.

(Also, I'm a data guy. I have no programming experience. If the answer involves programming, I'll hand it off to the web folks.)

Share this post


Link to post
Share on other sites
  • 0

ShWolf. Here's the HTML block for the map. Thanks for any suggestions.

Map it

G
1000
1000
3

Y
6
[@field:Address], [@field:City], [@field:State] [@field:Zip]

Station: [@field:station_name]

Address: [@field:address]

City: [@field:city]

Zip: [@field:zip]

Pass Rate: [@field:pass_rate]

600 S Tryon St, Charlotte, NC 28202

Share this post


Link to post
Share on other sites
  • 0

You are not closing div tag in here:

Station: [@field:station_name]

Address: [@field:address]

City: [@field:city]

Zip: [@field:zip]

Pass Rate: [@field:pass_rate]

600 S Tryon St, Charlotte, NC 28202

I think that is what causing the issue. :wink: :wink: :wink:

Share this post


Link to post
Share on other sites
  • 0

Hey,

I view the source of the web page and find that you have not deployed the DataPage and the map code in the right order. You should have the DataPage deploy code first and then the map deploy code. This should fix the issues.

This is also instructed in the map mashup instruction document section 2.Web Page Setup at http://howto.caspio.com/extensions/maps ... tions.html.

Best,

Bahar M.

Share this post


Link to post
Share on other sites
  • 0

Hi, also just to inform you, Google now restricts the rate which non-geocoded addresses can be plotted on a map (approximately 10 addresses per second). And, Google API key needs to have a billing enabled (though you will not be charged) to fully access the Geocoding API that you will place in the map. You also need to enable this two:

1. Geocoding API 

2. Maps Javascript API

 

Hope this helps. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...