Jump to content
  • 0
Sign in to follow this  
mdupras

Yahoo Map Mashup No Longer Functions

Question

We have several DataPages using the "old" map mashup JavaScript extension with Yahoo maps. Just last week, the maps on all the pages stopped functioning (locates just one point, out in the middle of the Atlantic Ocean -- all maps behave the same).

 

After a little bit of hunting, I found news that Yahoo's maps API was shut down about 2 years ago. However, ours all continued to function until just this week. So on one hand I assume this is why our maps no longer work, but on the other don't understand how they could have continued to function fine all this time.

 

Switching to Google maps is problematic. They now require geocodes, and the DataPages in question have 10s of 1000s of records -- geocoding that data through a service would be too costly for our organization.

 

Anyone have any insight on this issue or resolved the Yahoo maps quandry in some other way?

 

Thanks for your time!
 

-- MIchael Dupras

Syracuse Media Group

Syracuse, NY

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Yahoo shut down their map API support. You can try to use Map Mashup Version 7 http://howto.caspio.com/extensions/maps/map-mashup-instructions/map-mashup-version-7/

 

Yes, using Google with the Map Mashup v7 is an option, but as I mentioned the problem is requirement that the data be geocoded. Some of these datapages have tens of 1000s of records -- or even hundreds of 1000s -- and are updated reguarly, so I need to find a solution that doesn't require paying for batch geocoding.

 

Has anyone attempted to create a mapping extension similar to the "old" map mashup using MapQuest rather than Google or Yahoo?

 

Mike

Share this post


Link to post
Share on other sites
  • 0

You can also use the older version of Google which does not have geocoding limitation. This option is the quickest way to get your map up and running as you only need to take three steps to update the following items referring to the instruction at http://howto.caspio.com/extensions/maps/map-mashup-instructions/map-mashup-older-version.html:

 

In the instruction 1.3, change map type “Y†for Yahoo to “G†for Google.

In the instruction 1.4, change map type “Y†for Yahoo to “G†for Google (optional only if you have a Details Page).

In the instruction 2.2, change Yahoo deploy code with Google deploy code (replace “YourKeyHere†with your API Key registered for your domain).

Share this post


Link to post
Share on other sites
  • 0

Thanks everyone for the help. For a long time, the Map Mashup 7 instructions indicated that Google would only plot 10 or so non-geocoded addresses. Today, I noticed the information changed, to say "no more than 10 per second." Also, I think we had an outdated API key. So solves part of our problem, but yes -- non-geocoded loads painfully slowly ...

 

Mike

Share this post


Link to post
Share on other sites
  • 0

I ran into the same problem and I am only dealing with 150 or so records.  Prior to placing the data on Caspio I was using Yahoo and then Google to geocode addresses to lat/long values.  Geocoding from within Caspio is painfully slow as noted.  My problem occurred when Google apparently quit allowing use of automated queries to complete the geocoding.  I tried MapQuest (since Yahoo has gone away) and that did not work well.  Finally, I found a solution for the moment using Bing maps.  This page has an example:  http://msdn.microsoft.com/en-us/library/ff701714.aspx

 

I can't be of much help as to how you will batch generate your lat/longs.  I am using FoxPro to do so and that works for me at the moment (until Bing decides no automated querying for geocoding).

Share this post


Link to post
Share on other sites
  • 0

As of September 2013,Yahoo! terminated their free maps web services, as a result Yahoo Map are no longer supported .Upgrading to Map Mashup version 7 will require re-configuring your map, and you may want to consider geocoding your data for performance reasons if you are displaying more than 10 addresses per page.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...